No description, website, or topics provided.
Ruby
Switch branches/tags
Nothing to show
Clone or download
Latest commit 2eb3adc Nov 11, 2014

README.md

LATCH RUBY SDK

#### PREREQUISITES ####

USING THE SDK IN RUBY

  • Require "Latch". Keep in mind where the SDK is placed inside your folder structure.
	require_relative '/latch/Latch'
  • Create a Latch object with the "Application ID" and "Secret" previously obtained.
	api = Latch.new(appid, app_secret)
  • Call to Latch Server. Pairing will return an account id that you should store for future api calls
     pairResponse = api.pair(PAIRING_CODE_HERE)
     statusResponse = api.status(ACCOUNT_ID_HERE)
     unpairResponse = api.unpair(ACCOUNT_ID_HERE)
  • After every API call, get Latch response data and errors and handle them.
	responseData = response.data
	responseError = response.error