Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

embed: Embed doesn't work. (Trac #3771) #3771

Closed
elgg-gitbot opened this issue Feb 16, 2013 · 13 comments
Closed

embed: Embed doesn't work. (Trac #3771) #3771

elgg-gitbot opened this issue Feb 16, 2013 · 13 comments

Comments

@elgg-gitbot
Copy link

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

Original ticket http://trac.elgg.org/ticket/3771 on 41682757-01-16 by trac user illifly, assigned to unknown.

Elgg version: 1.8 Beta

Ive installed the new 1.8 version, testing around and found that i cant embed/upload a file when i using the "embed content" link on the upper right corner of the TinyMCE Editor. The window popup well but then i get the message on the select-image-tab "no items found", the same message on the tab upload!
i uploaded a file and tested again but the same message is shown...

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

brettp wrote on 41683215-04-29

This is just a problem with embed...it doesn't involve TinyMCE.

I think the problem is the File plugin isn't enabled and the error message doesn't prompt the user / admin to enable it.

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

Milestone changed to Elgg 1.8.1b by brettp on 41683215-04-29

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

Title changed from Image upload/select dont work on TinyMCE to Embed doesn't work. by brettp on 41683215-04-29

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

cash wrote on 41684039-06-26

Do we put a dependency in the plugin's manifest for now?

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

brettp wrote on 41684048-03-02

Yes. That's the simplest. People implementing their own embed-compatible plugins will need to remove the dep, but I don't see many people doing that right now.

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

cash wrote on 41689341-07-08

I just tested this with the file plugin and the upload tab does not ever show when you click on it.

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

trac user slyhne wrote on 41690728-01-23

I can confirm that embed doesn't work at all. With file plugin enabled it doesn't show the files and no upload form is shown.

Waiting for 1.8.1 is apparently the only option as this is a show stopper for me :-(

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

cash wrote on 41695050-10-25

There seem to be files missing. Hopefully, that's it.

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

trac user slyhne wrote on 41695945-08-11

cash

Could you provide a list of missing files, or should I just get the embed plugin from nightly or something?

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

cash wrote on 41696107-03-11

I have no idea. I'm hoping that Brett has these files and forgot to add them to the commit. You could try grabbing the embed plugin and file plugin from beta 2.

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

trac user Brett Profitt wrote on 41696571-11-04

Fixes #3771. Added missing files for embed support. Added requirement for file in embed's manifest.
Changeset: c5eb195

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

trac user Brett Profitt wrote on 41699203-07-01

Refs #3771. Fixed incorrect requires plugin name.
Changeset: bd15122

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

trac user Brett Profitt wrote on 41850784-01-05

Fixes #3771. Added missing files for embed support. Added requirement for file in embed's manifest.
Changeset: c5eb195

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant