Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

fuse4x installs properly but kext doesn't get loaded (10.8) #13647

Closed
SockPants opened this Issue · 6 comments

7 participants

@SockPants

There were no peculiarities during install. I tried installing it again, nothing changed. Does anyone have fuse4x working on 10.8?

The error I get is when using sshfs:

$ sshfs site.com: /Volumes/VPS
execl: No such file or directory
fuse4x kernel extension was not loaded. Please check /var/log/system.log for more information.

/var/log/system.log contained no mention of 'fuse'.

@anatol

Hi,

did you follow instructions from brew info fuse4x-kext

Also check if other log files contain info related to fuse4x: /var/log/debug.log /var/log/kernel.log (Apple all the time changes name for output kernel log file)

@smarek

I propose this bug to be closed, exactly these steps are solving the issue, recently tested on 10.8

@jacknagel
Owner

Closing.

@jacknagel jacknagel closed this
@ezmiller

I am having the same problem and following the instructions provided in brew info fuse4x-kext did not fix the problem. Now I am getting as a pop-up message the following error in /var/log/system.log:

com.apple.kextd[12]: Can't load /Library/Extensions/fuse4x.kext - authentication problems.

Does this have to do perhaps with permissions settings on some file?

@dazld

Followed instructions on brew info as above - and worked, but would be nice to have this as a warning when installing sshfs directly. Had to come here for help!

@sandrewh

I had to run sudo chgrp -R wheel /Library/Extensions/fuse4x.kext to fix authentication problems error.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.