Skip to content

Backwards-incompatible API changes should increment version number #2

maxhawkins opened this Issue Feb 1, 2013 · 1 comment

2 participants


Commits 0d4ee83 and e2d36a6 introduce backwards-incompatible API changes.

According to semver this means you should increment the version number to 2.0.0 or else make the changes backwards-compatible and increment to 1.1.0.

These changes caused problems for me because I specify ttt's version with '~> 1.0.0' in my gemfile. That means when I updated my bundle it automatically updated to the new, incompatible version and broke my build.

Please revert the backwards-incompatible changes or increment the version number to 2.0.0 to alert users of the change. Thanks!

@JMongol JMongol added a commit that referenced this issue Feb 1, 2013
@JMongol Increment version to 2.0.0
Fixes issue #2
JMongol commented Feb 1, 2013

You're right - sorry about that. I just pushed a fix for this. I'll push a new build of the gem up to rubygems as well when they come back online.

@JMongol JMongol closed this Feb 1, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.