Assets 4

Upgrade Guide

Attention!

  • Window Mixed Reality developers use Unity Editor 2017.2.0p1 MRTP 4
    • When building for Windows Mixed Reality target 10.0.16299 SDK.
  • HoloLens developers use Unity Editor 2017.1.2
    • When building for HoloLens be sure to target the 10.0.15063 SDK.
  • When upgrading to this release, delete all toolkit folders before importing the package.
  • Minimum Editor Compatibility for Unity 5.6 for HoloLens development ONLY.

Release Notes

  • (#1101) Updated Raycasting logic
  • (#1141, #1098) Ported Input Updates from Dev Branch
  • (#1106) Updated Medical Example

Breaking Changes from last release v1.2017.1.2

  • TryGetPosition is now TryGetPointerPosition
  • TryGetOrientation is now TryGetPointerRotation
  • SpeechKeywordRecognizedEventData is now SpeechEventData
  • All other changes should throw Obsolete warnings with suggested updates.