Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Heads Up: Hammer in TF2 displays textures at low resolution. #168

Open
reepblue opened this issue Aug 30, 2013 · 9 comments

Comments

Projects
None yet
4 participants
@reepblue
Copy link

commented Aug 30, 2013

In the Hammer version of TF2, I've just noticed that the materials on brushes and models are low resolution. When I load up tools for something else like HL2 or the SDK, it's fine.

Just want to let you know in-case you guys plan on merging the up-to date game tools with the SDK tools in the future. If this is a known issue, sorry to bring it up as I just looked at it today.

@JoeLudwig

This comment has been minimized.

Copy link
Contributor

commented Sep 3, 2013

Could you post some screenshots of the textures you're talking about?

@reepblue

This comment has been minimized.

Copy link
Author

commented Sep 4, 2013

tf2_low_res

It forces low res textures in the 3D viewport and the modelviewer for the current TF2 tools. I have a Radeon 5770, and these are the only tools so far that do this. The SDK tools (SP atleast) does not have this problem.

@reepblue

This comment has been minimized.

Copy link
Author

commented Sep 6, 2013

After today's SDK update, this issue is now in the SDK Base tools.

@SuperNexus4

This comment has been minimized.

Copy link

commented Sep 15, 2013

Is there a way I can fix this? I am having this issue again and I thought I had fixed it. It's frustrating how in the Hammer Editor of SSDK 2013 the textures are of low quality, yet in the L4D2 Hammer Editor they remain intact.

@reepblue

This comment has been minimized.

Copy link
Author

commented Sep 15, 2013

Talked to someone with a Nvidia GTX 650 that ran the current tools for the SDK, and he said that he does not have this issue. This may just be another ATI bug?

I personally rolled back my tools to the files before the 9/5 update.

@SuperNexus4

This comment has been minimized.

Copy link

commented Sep 15, 2013

I heard from someone that you can fix this issue by changing the ConVar Mat Picmip values from 2 to -1 in the DXSUPPORT files. I have already tried doing that and I still get the low resolution graphics as shown in my models, textures, entites, etc.

@reepblue

This comment has been minimized.

Copy link
Author

commented Sep 16, 2013

Neico, someone I just chatted on Steam just a min ago found out that it was inputsystem.dll.

Here is the fixed dll. (From the tools before this update)
https://dl.dropboxusercontent.com/u/16218991/hammer/inputsystem.zip

@neico

This comment has been minimized.

Copy link
Contributor

commented Sep 16, 2013

Hi there~

anyways, it works with the inputsystem.dll that can be found inside Half-Life 2\bin where hammer shows up the textures just fine.

I don't even know why the inputsystem would impact something related to rendering materials, let alone their quality :/

This issue happens on Source 2013 SP & MP as well as other Games such as Team Fortress 2 (didn't test the dll replaced on the last one tough)

@reepblue

This comment has been minimized.

Copy link
Author

commented Sep 24, 2013

After TF2's update, this issue seems to be fixed. (inputsystem.dll is updated) I will close this issue when this update applies to the SDK base. For the time being, if you have this issue, see the solutions above.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.