Skip to content

Denial of Service in @hapi/hapi

High severity GitHub Reviewed Published Sep 3, 2020 • Updated Aug 13, 2022

Package

npm @hapi/hapi (npm)

Affected versions

< 18.4.1
>= 19.0.0, < 19.1.1

Patched versions

18.4.1
19.1.1

Description

Versions of @hapi/hapi prior to 18.4.1 or 19.1.1 are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

Recommendation

Upgrade to versions 18.4.1, 19.1.1 or later.

References

Severity

High

Weaknesses

No CWEs

CVE ID

No known CVE

GHSA ID

GHSA-23vw-mhv5-grv5

Source code

No known source code
Checking history
See something to contribute? Suggest improvements for this vulnerability.