Skip to content

Denial of Service in subtext

high severity Published Sep 3, 2020 • Updated Sep 29, 2021

Package

npm subtext (npm)

Affected versions

>= 0.0.0

Patched versions

None

Description

All versions of subtext are vulnerable to Denial of Service (DoS). The package fails to enforce the maxBytes configuration for payloads with chunked encoding that are written to the file system. This allows attackers to send requests with arbitrary payload sizes, which may exhaust system resources leading to Denial of Service.

Recommendation

This package is not actively maintained and has been moved to @hapi/subtext where version 6.1.2.

References

GHSA ID

GHSA-2mvq-xp48-4c77