Skip to content

Denial of Service in js-yaml

moderate severity Published Jun 5, 2019 • Updated Aug 4, 2021

Package

npm js-yaml (npm)

Affected versions

< 3.13.0

Patched versions

3.13.0

Description

Versions of js-yaml prior to 3.13.0 are vulnerable to Denial of Service. By parsing a carefully-crafted YAML file, the node process stalls and may exhaust system resources leading to a Denial of Service.

Recommendation

Upgrade to version 3.13.0.

References

GHSA ID

GHSA-2pr6-76vf-7546

CVSS Score

5.9 Moderate
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H