Skip to content

npm Vulnerable to Global node_modules Binary Overwrite

High severity GitHub Reviewed Published Dec 12, 2019 in npm/cli • Updated Jan 29, 2023

Package

npm npm (npm)

Affected versions

< 6.13.4

Patched versions

6.13.4

Description

Versions of the npm CLI prior to 6.13.4 are vulnerable to a Global node_modules Binary Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations.

For example, if a package was installed globally and created a serve binary, any subsequent installs of packages that also create a serve binary would overwrite the first binary. This will not overwrite system binaries but only binaries put into the global node_modules directory.

This behavior is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.

Recommendation

Upgrade to version 6.13.4 or later.

References

Last updated Jan 29, 2023
Reviewed Jun 16, 2020
Published to the GitHub Advisory Database Dec 13, 2019
Published by the National Vulnerability Database Dec 13, 2019
@andreeleuterio andreeleuterio published to npm/cli Dec 12, 2019

Severity

High
7.7
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
High
Privileges required
Low
User interaction
Required
Scope
Changed
Confidentiality
High
Integrity
High
Availability
None
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N

CVE ID

CVE-2019-16777

GHSA ID

GHSA-4328-8hgf-7wjr

Source code

Credits

Checking history
See something to contribute? Suggest improvements for this vulnerability.