Skip to content

Prototype Pollution in set-value

critical severity GitHub Reviewed Published Aug 27, 2019 • Updated Aug 17, 2021

Package

npm set-value (npm)

Affected versions

< 2.0.1
= 3.0.0

Patched versions

2.0.1
3.0.1

Description

Versions of set-value prior to 3.0.1 or 2.0.1 are vulnerable to Prototype Pollution. The set function fails to validate which Object properties it updates. This allows attackers to modify the prototype of Object, causing the addition or modification of an existing property on all objects.

Recommendation

If you are using set-value 3.x, upgrade to version 3.0.1 or later.
If you are using set-value 2.x, upgrade to version 2.0.1 or later.

References

CVE ID

CVE-2019-10747

CVSS Score

9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H