Skip to content

Cross-Site Scripting in materialize-css

Moderate severity GitHub Reviewed Published Apr 9, 2019 • Updated Sep 2, 2021

Package

npm materialize-css (npm )

Affected versions

<= 1.0.0

Patched versions

None

Description

All versions of materialize-css are vulnerable to Cross-Site Scripting. The autocomplete component does not sufficiently sanitize user input, allowing an attacker to execute arbitrary JavaScript code if the malicious input is rendered by a user.

Recommendation

No fix is currently available. Consider using an alternative module until a fix is made available.

References

Severity

Moderate
6.1
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
Required
Scope
Changed
Confidentiality
Low
Integrity
Low
Availability
None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Weaknesses

CVE ID

CVE-2019-11003

GHSA ID

GHSA-7752-f4gf-94gc

Source code

No known source code
See something to contribute? Suggest improvements for this vulnerability.