Skip to content

Authentication Bypass in samlify

High severity GitHub Reviewed Published Jan 4, 2018 • Updated Sep 7, 2021

Package

npm samlify (npm)

Affected versions

< 2.3.0

Patched versions

2.3.0

Description

Versions of samlify prior to 2.4.0 are vulnerable to Authentication Bypass. The package fails to prevent XML Signature Wrapping, allowing tokens to be reused with different usernames. A remote attacker can modify SAML content for a SAML service provider without invalidating the cryptographic signature, which may allow attackers to bypass primary authentication for the affected SAML service provider.

Recommendation

Upgrade to version 2.4.0 or later

References

Severity

High
7.5
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
High
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Weaknesses

CVE ID

CVE-2017-1000452

GHSA ID

GHSA-8jjf-w7j6-323c

Source code

Checking history
See something to contribute? Suggest improvements for this vulnerability.