Skip to content

Arbitrary Code Execution in underscore

high severity Published May 6, 2021 • Updated Aug 25, 2021

Package

npm underscore (npm)

Affected versions

>= 1.3.2, < 1.12.1

Patched versions

1.12.1

Description

The package underscore from 1.13.0-0 and before 1.13.0-2, from 1.3.2 and before 1.12.1 are vulnerable to Arbitrary Code Execution via the template function, particularly when a variable property is passed as an argument as it is not sanitized.

References

CVE ID

CVE-2021-23358

CVSS Score

9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H