Skip to content

Remote Code Execution in electron

high severity Published Aug 23, 2018 • Updated Sep 14, 2021

Package

npm electron (npm)

Affected versions

>= 1.7.0, < 1.7.16
>= 1.8.0, < 1.8.8
>= 2.0.0, < 2.0.8

Patched versions

1.7.16
1.8.8
2.0.8

Description

GitHub Electron 1.7.15, 1.8.7, 2.0.7, and 3.0.0-beta.6, in certain scenarios involving IFRAME elements and "nativeWindowOpen: true" or "sandbox: true" options, is affected by a WebPreferences vulnerability that can be leveraged to perform remote code execution.

More information to determine if you are impacted can be found on the electron blog.

Recommendation

Upgrade Electron to >=3.0.0-beta.7, >=2.0.8, >=1.8.8, or >=1.7.16."

References

CVE ID

CVE-2018-15685

CVSS Score

8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H