Skip to content

Signature Malleabillity in elliptic

high severity GitHub Reviewed Published Jul 29, 2020 • Updated Sep 23, 2021

Package

npm elliptic (npm)

Affected versions

< 6.5.3

Patched versions

6.5.3

Description

The Elliptic package before version 6.5.3 for Node.js allows ECDSA signature malleability via variations in encoding, leading '\0' bytes, or integer overflows. This could conceivably have a security-relevant impact if an application relied on a single canonical signature.

References

CVE ID

CVE-2020-13822

CVSS Score

7.7 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L