Skip to content
Browse files

fix for gems that `require 'ammeter/init'` before `require 'rails'`

  • Loading branch information...
1 parent fa7e98f commit 3f448aa333042e71d0e0b64db603a6ee4d424083 @alexrothenberg committed
2  features/templates/my_railties_gem/spec/spec_helper.rb
@@ -1,5 +1,5 @@
require 'bundler/setup'
-require 'rails'
require 'ammeter/init'
+require 'rails'
1  lib/ammeter/init.rb
@@ -1,5 +1,6 @@
require 'ammeter/rspec/generator/example.rb'
require 'ammeter/rspec/generator/matchers.rb'
+require 'rails'
if Rails.application.nil?
# We are in a gem so create test Rails app

0 comments on commit 3f448aa

Please sign in to comment.
Something went wrong with that request. Please try again.