Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Removes unnecessary packages from setup_requires #16139

Merged

Conversation

@potiuk
Copy link
Member

@potiuk potiuk commented May 28, 2021

This change removes unnecessary dependencies from setup_requires:

  • docutils are not needed in setup requires and actually
    having them here caused harmful upgrade even if docutils
    are limited to <0.17 elsewhere
  • setup_tools should not be needed in setup_requires (by
    the time setup_requires are parsed, they should be already
    installed
  • bowler is not needed any more in setup.py (we got rid of it
    when we got rid of backport packages.

^ Add meaningful description above

Read the Pull Request Guidelines for more information.
In case of fundamental code change, Airflow Improvement Proposal (AIP) is needed.
In case of a new dependency, check compliance with the ASF 3rd Party License Policy.
In case of backwards incompatible changes please leave a note in UPDATING.md.

@potiuk potiuk requested a review from ashb as a code owner May 28, 2021
@potiuk potiuk requested review from kaxil, eladkal and mik-laj May 28, 2021
@potiuk
Copy link
Member Author

@potiuk potiuk commented May 28, 2021

cc: @uranusjr

@potiuk potiuk force-pushed the remove-unnecessary-packages-from-setup-requires branch from 15bb346 to 7834585 May 28, 2021
@github-actions
Copy link

@github-actions github-actions bot commented May 28, 2021

The PR most likely needs to run full matrix of tests because it modifies parts of the core of Airflow. However, committers might decide to merge it quickly and take the risk. If they don't merge it quickly - please rebase it to the latest master at your convenience, or amend the last commit of the PR, and push it with --force-with-lease.

kaxil
kaxil approved these changes May 28, 2021
This change removes unnecessary dependencies from setup_requires:

* docutils are not needed in setup requires and actually
  having them here caused harmful upgrade even if docutils
  are limited to <0.17 elsewhere
* setup_tools should not be needed in setup_requires (by
  the time setup_requires are parsed, they should be already
  installed
* bowler is not needed any more in setup.py (we got rid of it
  when we got rid of backport packages.

Also docutils<0.17 limitation is moved to install_requires
because docutils was already a transitive dependency of
airflow without extras and it could be upgraded even if there
is a limitation in extra.
@potiuk potiuk force-pushed the remove-unnecessary-packages-from-setup-requires branch from 7834585 to 96ef5fc May 28, 2021
@potiuk potiuk merged commit b605987 into apache:master May 28, 2021
13 checks passed
@potiuk potiuk deleted the remove-unnecessary-packages-from-setup-requires branch May 28, 2021
andormarkus pushed a commit to andormarkus/airflow that referenced this issue Jun 5, 2021
This change removes unnecessary dependencies from setup_requires:

* docutils are not needed in setup requires and actually
  having them here caused harmful upgrade even if docutils
  are limited to <0.17 elsewhere
* setup_tools should not be needed in setup_requires (by
  the time setup_requires are parsed, they should be already
  installed
* bowler is not needed any more in setup.py (we got rid of it
  when we got rid of backport packages.

Also docutils<0.17 limitation is moved to install_requires
because docutils was already a transitive dependency of
airflow without extras and it could be upgraded even if there
is a limitation in extra.
potiuk added a commit to potiuk/airflow that referenced this issue Jun 22, 2021
This change removes unnecessary dependencies from setup_requires:

* docutils are not needed in setup requires and actually
  having them here caused harmful upgrade even if docutils
  are limited to <0.17 elsewhere
* setup_tools should not be needed in setup_requires (by
  the time setup_requires are parsed, they should be already
  installed
* bowler is not needed any more in setup.py (we got rid of it
  when we got rid of backport packages.

Also docutils<0.17 limitation is moved to install_requires
because docutils was already a transitive dependency of
airflow without extras and it could be upgraded even if there
is a limitation in extra.

(cherry picked from commit b605987)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

4 participants