Skip to content
Add-on to jQuery Validation to make unobtrusive validation compatible to Bootstrap v4.x.
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
dist
.gitignore Gitignore Oct 4, 2017
LICENSE
README.md
package-lock.json
package.json Publish version 2.2.0 Dec 18, 2018

README.md

Bootstrap v4.x Extension for jQuery Validation Unobtrusive

This library is a extension for jQuery Validation Unobtrusive and jQuery Validation. It ensures the full compatibility between Bootstrap v4.x and jQuery Validation in interaction with ASP.NET Core.

Installation

You can get this library in different ways:

Install with npm: npm i jquery-validation-unobtrusive-bootstrap

Install with yarn: yarn add jquery-validation-unobtrusive-bootstrap

Clone the git repository: git clone https://github.com/brecons/jquery-validation-unobtrusive-bootstrap.git

Usage

Just include the javascript after jquery.validate.unobtrusive and that's it!

<script src="~/lib/jquery/dist/jquery.slim.min.js" type="text/javascript"></script>
<script src="~/lib/jquery-validation/dist/jquery.validate.js"></script>
<script src="~/lib/jquery-validation-unobtrusive/jquery.validate.unobtrusive.js"></script>
<script src="~/lib/jquery-validation-unobtrusive-bootstrap/dist/unobtrusive-bootstrap.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.11.0/umd/popper.min.js" type="text/javascript"></script>
<script src="~/lib/bootstrap/dist/js/bootstrap.min.js" type="text/javascript"></script>

License

This project has been released under the MIT License. This license applies ONLY to the source of this repository and does not extend to any other Brecons distribution or variant, or any other 3rd party libraries used in repository.

Copyright © 2016 - 2019 Bremus Solutions

You can’t perform that action at this time.