Enables TLS on SMTP connections (for services like GMail)
Latest commit c05ff01 Dec 22, 2009 @yn yn committed with bkeepers The test wasn't working under rubygems 1.3.5 and rails 2.3.5. Fixed t…
…he test, but probably broke backwards compatibility in the meantime. The plugin code itself was not touched


= action_mailer_optional_tls
Allows Google Mail SMTP to be used with Ruby on Rails' ActionMailer.

== Install
  ./script/plugin install git://github.com/collectiveidea/action_mailer_optional_tls.git

== Configure

Add the following to your environment.rb file:

 ActionMailer::Base.smtp_settings = {
    :tls => true,
    :address => "smtp.gmail.com",
    :port => "587",
    :domain => "YOURDOMAIN",
    :authentication => :plain,
    :user_name => "GOOGLEUSERNAME",
    :password => "GOOGLEPASSWORD" 

== Webified Documentation


== Credits

This useful plugin is hosted at http://douglasfshearer.com as a public service, due to the continued downtime of http://kylemaxwell.com

Douglas F Shearer is neither the creator nor maintainer of this work, so if it's broke, it's broke.

Created by Kyle Maxwell - http://kylemaxwell.com/

Forked and adjusted by Nathan L. Walls - http://wallscorp.us/ to resolve the issue describe here: http://blog.inspired.no/smtp-error-while-using-gmail-in-rails-271 and satisfy differences between Ruby 1.8.6 and Ruby 1.8.7. Note: this is brittle, but solves a need.