Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cypress open dont show up window #2667

Closed
aldarund opened this issue Oct 26, 2018 · 19 comments
Closed

Cypress open dont show up window #2667

aldarund opened this issue Oct 26, 2018 · 19 comments
Assignees
Labels
Milestone

Comments

@aldarund
Copy link

@aldarund aldarund commented Oct 26, 2018

Current behavior:

cypress open dont show up cypress window. It load for sometime and nothing.

cypress run work fine.

I did clean cache ( c:\Users\shape\AppData\Roaming\Cypress\ & c:\Users\shape\AppData\Local\Cypress\ ), i did reinstall cypress. No luck.

here is cypress log from cypress open
https://gist.github.com/aldarund/7261313ecf1a729608f4d34008914c81

There is like 4-5 Cypress.exe running after open.
And when i stop it i see shortly a blinking window ( like milliseconds)

Desired behavior:

Cypress opens a runner and window show up

Steps to reproduce:

just cypress open

Versions

Cypress 3.1
Node 11
Windows 10 x64
Chrome Version 71.0.3578.20 (Official Build) beta (64-bit)

@aldarund aldarund changed the title Cypress Open dont show up any window Cypress Open dont show up window Oct 26, 2018
@aldarund aldarund changed the title Cypress Open dont show up window Cypress open dont show up window Oct 26, 2018
@Konstruktour
Copy link

@Konstruktour Konstruktour commented Oct 29, 2018

are u sure that it is not opened at all? sometime i have the issue that the dashboard/runner is shown outside of the screen.

@aldarund
Copy link
Author

@aldarund aldarund commented Oct 29, 2018

@Konstruktour Yes, it dont open. There no window in task panel and as i remember there should be. The only thing that i can notice is that when i stop some window ( console window ??) blinking and thats all.

@jennifer-shehane
Copy link
Member

@jennifer-shehane jennifer-shehane commented Oct 30, 2018

Hey @aldarund, can you run cypress open with another project, like our cypress-example-kitchensink?

I would like to know if it is related to your project's test code or not.

@aldarund
Copy link
Author

@aldarund aldarund commented Oct 30, 2018

@jennifer-shehane it is not related to project code, it was working before on same code. I tried on your linked repo and its same behaviour.
Let me know what else i can provide to help debug it :)

@zerdos
Copy link
Contributor

@zerdos zerdos commented Oct 31, 2018

The problem is node 11, on windows environment. Works fine with node 10.3

@zerdos
Copy link
Contributor

@zerdos zerdos commented Oct 31, 2018

maybe related:
nodejs/node#21316

@zerdos
Copy link
Contributor

@zerdos zerdos commented Oct 31, 2018

Yes, adding windowsHide in the spawn options (cypress/cli/lib/exec/spawn.js, line 90), solves the problem in windows with node 11.

I will send a PR later;)

@ryan-mars
Copy link

@ryan-mars ryan-mars commented Nov 5, 2018

Having the same issue here. Node 11 + Windows 10 + Cypress 3.1.1

Running node_modules\.bin\cypress open doesn't show the browser. cypress run works fine.

@zerdos
Copy link
Contributor

@zerdos zerdos commented Nov 7, 2018

PR added.

@Liverpudlian
Copy link

@Liverpudlian Liverpudlian commented Nov 7, 2018

Awesome, just experiencing this issue now 👍

@chrisbreiding
Copy link
Contributor

@chrisbreiding chrisbreiding commented Nov 13, 2018

The code for this is done, but this has yet to be released. We'll update this issue and reference the changelog when it's released.

@brian-mann
Copy link
Member

@brian-mann brian-mann commented Nov 19, 2018

Released in 3.1.2.

@aldarund
Copy link
Author

@aldarund aldarund commented Nov 20, 2018

@brian-mann @chrisbreiding 3.1.2 dont fix the issue. Your latest refactoring to that PR broke it again.. After them you are setting windowsHide to getEnvOverrides which ends up into env vars and it dont work.

@xiaoxu12
Copy link

@xiaoxu12 xiaoxu12 commented Nov 21, 2018

Why not show up windows?When do you want to solve it. It also can not open chrome in window 10

@Bkucera
Copy link
Member

@Bkucera Bkucera commented Nov 28, 2018

the problem is we set windowsHide as a prop of options.env, when it should be a prop of options
https://nodejs.org/api/child_process.html#child_process_child_process_spawn_command_args_options
I'll open up a PR to fix this

@Bkucera Bkucera reopened this Nov 28, 2018
Bkucera added a commit that referenced this issue Nov 28, 2018
brian-mann added a commit that referenced this issue Dec 3, 2018
* Revert "Issue 21316 windows node11 (#2699) (fixes #2667)"

This reverts commit 54ce93b.

* add windowsHide prop

* fix test name
@brian-mann
Copy link
Member

@brian-mann brian-mann commented Dec 3, 2018

Released in 3.1.3.

@Pascalmh
Copy link

@Pascalmh Pascalmh commented Sep 19, 2019

In case this still happens you can Shift + Right Click on the Icon in the Toolbar an then click Maximize - that should bring the Window into the foreground and your are able to use it.

@grzegorz-jazurek
Copy link

@grzegorz-jazurek grzegorz-jazurek commented Oct 4, 2019

In case this still happens you can Shift + Right Click on the Icon in the Toolbar an then click Maximize - that should bring the Window into the foreground and your are able to use it.

@Pascalmh thanks man!

@PawelEpicode
Copy link

@PawelEpicode PawelEpicode commented Apr 20, 2020

@grzegorz-jazurek you saved my life :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.