Skip to content
Permalink
Browse files
ci: Remove Node 16 CI prerelease workaround (#14935)
Refs #14933

* Build: Upgrade to v8-compatible JSDoc plugin

* Build: Remove npm force install in CI

This reverts the change from #14933 now that all peer dependencies are
valid with ESLint v8.0.0.
  • Loading branch information
btmills committed Oct 26, 2021
1 parent 2774043 commit 67949bd9f3cbda08442d2e5946feb9a4f8b22d85
Show file tree
Hide file tree
Showing 2 changed files with 1 addition and 6 deletions.
@@ -42,11 +42,6 @@ jobs:
node-version: ${{ matrix.node }}
- name: Install Packages
run: npm install
# TODO(btmills): Remove Node 16 --force branching after releasing v8.0.0 final.
if: ${{ !startswith(matrix.node, '16') && !startswith(matrix.node, '17') }}
- name: Install Packages
run: npm install --force
if: ${{ startswith(matrix.node, '16') || startswith(matrix.node, '17') }}
- name: Test
run: node Makefile mocha
- name: Fuzz Test
@@ -101,7 +101,7 @@
"eslint-plugin-eslint-comments": "^3.2.0",
"eslint-plugin-eslint-plugin": "^4.0.1",
"eslint-plugin-internal-rules": "file:tools/internal-rules",
"eslint-plugin-jsdoc": "^36.0.6",
"eslint-plugin-jsdoc": "^37.0.0",
"eslint-plugin-node": "^11.1.0",
"eslint-release": "^3.1.2",
"eslump": "^3.0.0",

0 comments on commit 67949bd

Please sign in to comment.