Skip to content

Accept Paramiko >=1.13 with Python >=2.6 #1105

Closed
Arfrever opened this Issue Mar 25, 2014 · 1 comment

2 participants

@Arfrever
--- setup.py
+++ setup.py
@@ -26,6 +26,11 @@ pip, with `pip install fabric==dev`.
 For more information, please see the Fabric website or execute ``fab --help``.
 """ % (get_version('branch'), readme)

+if sys.version_info[:2] < (2, 6):
+    install_requires=['paramiko>=1.10,<1.13']
+else:
+    install_requires=['paramiko>=1.10']
+
 setup(
     name='Fabric',
     version=get_version('short'),
@@ -37,7 +42,7 @@ setup(
     packages=find_packages(),
     test_suite='nose.collector',
     tests_require=['nose', 'fudge<1.0'],
-    install_requires=['paramiko>=1.10,<1.13'],
+    install_requires=install_requires,
     entry_points={
         'console_scripts': [
             'fab = fabric.main:main',
@bitprophet
Fabric member

Thanks, can't see a good reason not to do it this way :) cheers!

@lundberg lundberg added a commit to 5monkeys/fabric that referenced this issue Apr 7, 2014
@lundberg lundberg Merge branch 'refs/heads/master' into develop
* refs/heads/master:
  Changelog re #1105, fixes #1105
  Permit Paramiko >=1.13 under Python 2.6+
  Bump 1.7.3 for setup.py tweak
  Modified changelog w/o releasing...
  Update Releases requirement for needed bugfixes
  Add 1.8.3 to changelog
  Update changelog for 1.7.3

Conflicts:
	docs/changelog.rst
95cea31
@koobs koobs added a commit to freebsd/freebsd-ports that referenced this issue Jun 13, 2014
@koobs koobs devel/py-fabric: Update to 1.8.4, fix w/ paramiko > 1.13
- Update to 1.8.4 (containing fix for paramiko > 1.13)
- Tweak RUN_DEPENDS on paramiko to match version string in setup.py

Changes:

    * Enhance setup.py to allow Paramiko 1.13+ under Python 2.6+. [1]
    * Treat paths that begin with tilde "~" as absolute lute paths instead of
      relative. [2]

[1] fabric/fabric#1105
[2] fabric/fabric#898

PR:		190856
Reported by:	blackmore at pichove dot org
a23e155
@knu knu pushed a commit to idaemons/freebsd-ports that referenced this issue Jun 15, 2014
koobs devel/py-fabric: Update to 1.8.4, fix w/ paramiko > 1.13
- Update to 1.8.4 (containing fix for paramiko > 1.13)
- Tweak RUN_DEPENDS on paramiko to match version string in setup.py

Changes:

    * Enhance setup.py to allow Paramiko 1.13+ under Python 2.6+. [1]
    * Treat paths that begin with tilde "~" as absolute lute paths instead of
      relative. [2]

[1] fabric/fabric#1105
[2] fabric/fabric#898

PR:		190856
Reported by:	blackmore at pichove dot org


git-svn-id: svn+ssh://svn.freebsd.org/ports/head@357658 35697150-7ecd-e111-bb59-0022644237b5
8a11921
@knu knu pushed a commit to idaemons/freebsd-ports that referenced this issue Jun 15, 2014
koobs devel/py-fabric: Update to 1.8.4, fix w/ paramiko > 1.13
- Update to 1.8.4 (containing fix for paramiko > 1.13)
- Tweak RUN_DEPENDS on paramiko to match version string in setup.py

Changes:

    * Enhance setup.py to allow Paramiko 1.13+ under Python 2.6+. [1]
    * Treat paths that begin with tilde "~" as absolute lute paths instead of
      relative. [2]

[1] fabric/fabric#1105
[2] fabric/fabric#898

PR:		190856
Reported by:	blackmore at pichove dot org


git-svn-id: svn+ssh://svn.freebsd.org/ports/head@357658 35697150-7ecd-e111-bb59-0022644237b5
52e56a3
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.