Skip to content
Compare
Choose a tag to compare

5.0.0

@antonmedv antonmedv released this
· 202 commits to main since this release
Compare
Choose a tag to compare
   __/\\\\\\\\\\\__/\\\____/\\\_     
    _\///////\\\/__\///\\\/\\\/__    
     ______/\\\/______\///\\\/____   
      ____/\\\/_________/\\\/\\\___  
       __/\\\\\\\\\\\__/\\\/\///\\\_ 
        _\///////////__\///____\///__

Updated dependencies

 chalk               ^4.1.2  →   ^5.0.0
 globby             ^12.0.1  →  ^13.1.1
 node-fetch          ^2.6.1  →   ^3.2.0

Added feature

Added YAML package.

let {foo} = YAML.parse('foo: bar')

Breaking changes

This release drops build of CommonJS version and support for .ts extension by zx bin.

TypeScript is still supported, for example, via ts-node:

node --loader ts-node/esm script.ts

Also, a new Node version requirement is >= 16.0.0.