This is a Python library for accessing resources protected by OAuth 2.0.
Clone or download
houglum Release v4.1.3 and update OAuth2 URIs. Fixes #742. (#743)
Release v4.1.3 and update OAuth2 URIs. Fixes #742.
Latest commit 50d2053 Sep 7, 2018

README.md

Build Status Coverage Status Documentation Status

This is a client library for accessing resources protected by OAuth 2.0.

Note: oauth2client is now deprecated. No more features will be added to the libraries and the core team is turning down support. We recommend you use google-auth and oauthlib. For more details on the deprecation, see oauth2client deprecation.

Installation

To install, simply run the following command in your terminal:

$ pip install --upgrade oauth2client

Contributing

Please see the CONTRIBUTING page for more information. In particular, we love pull requests -- but please make sure to sign the contributor license agreement.

Supported Python Versions

We support Python 2.7 and 3.4+. More information in the docs.