Skip to content
The Holiday API client wrapper written in Rust
Rust
Branch: master
Clone or download

Latest commit

Fetching latest commit…
Cannot retrieve the latest commit at this time.

Files

Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
src
.gitignore
Cargo.toml
LICENSE
README.md
appveyor.yml

README.md

holiday-api-rust

The HolidayAPI client wrapper written in Rust

Service Status
AppveyorCI Build status
crates.io crates.io

Pure Rust bindings to the Holiday API.

Dependencies and support

holiday-api-rust is intended to work on all tier 1 supported Rust systems:

  • MacOSX
  • Linux
  • Windows

Minimum Compiler Version

Due to the use of certain features holiday-api-rust requires rustc version 1.18 or higher.

Getting Started

Add the following to your Cargo.toml

[dependencies]
holiday_api_rust = "0.3.1"
serde_json = "1.0"

Then in your lib.rs or main.rs file add:

extern crate holiday_api_rust;

let client = HolidayAPIClient::new("HolidayAPI key here");
match client.search_holidays("2019", "BR") {
    Err(e) => eprintln!("{:?}", e),
    Ok(holidays) => {
        for holiday in holidays {
            println!("Holiday: {} | Date: {} | Country: {}", holiday.name, holiday.date, holiday.country);
        }
    }
}

License

Licensed under

You can’t perform that action at this time.