cabal-install's build-depends need relaxing for GHC 7.2 #862

Closed
bos opened this Issue May 24, 2012 · 2 comments

Comments

Projects
None yet
1 participant
Contributor

bos commented May 24, 2012

(Imported from Trac #872, reported by atsampson on 2011-08-13)

cabal-install has a pretty conservative set of package versions in its build-depends. GHC 7.2 ships with newer versions of some of them. The attached patch relaxes the version constraints enough for it to build (on Linux, at least).

Contributor

bos commented May 24, 2012

(Imported comment by Veinor on 2011-08-13)

Are there any plans to fix this, or are we waiting to see what 7.4 uses?

Contributor

bos commented May 24, 2012

(Imported comment by @kosmikus on 2012-01-03)

The next release should build ok with current versions of GHC. I'm marking this as a "duplicate" of the more recent #906.

@bos bos closed this May 24, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment