Permalink
Browse files

Add Hubot 2.3.0 compatibility & bump to v1.0.8

  • Loading branch information...
1 parent 7c3f7b6 commit dd71c91dd2c602cd76e1c4f9cd6f6dfd8b3f6579 @powdahound powdahound committed Jul 18, 2012
Showing with 6 additions and 8 deletions.
  1. +2 −2 README.md
  2. +1 −1 package.json
  3. +3 −5 src/hipchat.coffee
View
@@ -10,8 +10,8 @@ This is a HipChat-specific version of the more general [instructions in the Hubo
1. Edit `hubot/packages.json` and add `hubot-hipchat` to the `dependencies` section. It should look something like this:
"dependencies": {
- "hubot-hipchat": ">= 1.0.7",
- "hubot": ">= 2.0.1",
+ "hubot-hipchat": ">= 1.0.8",
+ "hubot": ">= 2.3.0",
...
}
View
@@ -1,6 +1,6 @@
{
"name": "hubot-hipchat",
- "version": "1.0.7",
+ "version": "1.0.8",
"author": "hipchat",
"keywords": "github hubot hipchat adapter",
"description": "A Hipchat adapter for hubot",
View
@@ -1,8 +1,6 @@
-Robot = require('hubot').robot()
-Adapter = require('hubot').adapter()
-
-HTTPS = require 'https'
-Wobot = require('wobot').Bot
+{Adapter,Robot} = require 'hubot'
+HTTPS = require 'https'
+Wobot = require('wobot').Bot
class HipChat extends Adapter
send: (user, strings...) ->

1 comment on commit dd71c91

Contributor

powdahound commented on dd71c91 Jul 18, 2012

Forgot to mention that this fixes #35

Please sign in to comment.