Permalink
Browse files

hello world

  • Loading branch information...
0 parents commit 28da13e3e6814c1c4e0c9620a7787d540ea6c4c3 @igrigorik committed Aug 4, 2013
Showing with 81 additions and 0 deletions.
  1. +17 −0 .gitignore
  2. +4 −0 Gemfile
  3. +29 −0 README.md
  4. +1 −0 Rakefile
  5. +23 −0 http2-parser.gemspec
  6. +2 −0 lib/http2/parser.rb
  7. +5 −0 lib/http2/parser/version.rb
@@ -0,0 +1,17 @@
+*.gem
+*.rbc
+.bundle
+.config
+.yardoc
+Gemfile.lock
+InstalledFiles
+_yardoc
+coverage
+doc/
+lib/bundler/man
+pkg
+rdoc
+spec/reports
+test/tmp
+test/version_tmp
+tmp
@@ -0,0 +1,4 @@
+source 'https://rubygems.org'
+
+# Specify your gem's dependencies in http2-parser.gemspec
+gemspec
@@ -0,0 +1,29 @@
+# Http2::Parser
+
+TODO: Write a gem description
+
+## Installation
+
+Add this line to your application's Gemfile:
+
+ gem 'http2-parser'
+
+And then execute:
+
+ $ bundle
+
+Or install it yourself as:
+
+ $ gem install http2-parser
+
+## Usage
+
+TODO: Write usage instructions here
+
+## Contributing
+
+1. Fork it
+2. Create your feature branch (`git checkout -b my-new-feature`)
+3. Commit your changes (`git commit -am 'Add some feature'`)
+4. Push to the branch (`git push origin my-new-feature`)
+5. Create new Pull Request
@@ -0,0 +1 @@
+require "bundler/gem_tasks"
@@ -0,0 +1,23 @@
+# coding: utf-8
+lib = File.expand_path('../lib', __FILE__)
+$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
+require 'http2/parser/version'
+
+Gem::Specification.new do |spec|
+ spec.name = "http2-parser"
+ spec.version = Http2::Parser::VERSION
+ spec.authors = ["Ilya Grigorik"]
+ spec.email = ["ilya@igvita.com"]
+ spec.description = %q{TODO: Write a gem description}
+ spec.summary = %q{TODO: Write a gem summary}
+ spec.homepage = ""
+ spec.license = "MIT"
+
+ spec.files = `git ls-files`.split($/)
+ spec.executables = spec.files.grep(%r{^bin/}) { |f| File.basename(f) }
+ spec.test_files = spec.files.grep(%r{^(test|spec|features)/})
+ spec.require_paths = ["lib"]
+
+ spec.add_development_dependency "bundler", "~> 1.3"
+ spec.add_development_dependency "rake"
+end
@@ -0,0 +1,2 @@
+require "http2/parser/version"
+
@@ -0,0 +1,5 @@
+module Http2
+ module Parser
+ VERSION = "0.0.1"
+ end
+end

0 comments on commit 28da13e

Please sign in to comment.