Skip to content
Permalink
Browse files

need gnutls.h, socat on xenial

add pip freeze for good measure
  • Loading branch information
minrk committed Apr 12, 2019
1 parent 9de8d87 commit b19d22e26d0cebc4c0a3731b76526232fc684212
Showing with 7 additions and 7 deletions.
  1. +3 −0 .travis.yml
  2. +4 −7 ci/install.sh
@@ -14,13 +14,16 @@ branches:
before_install:
- nvm install 8; nvm use 8
install:
# need gnutls headers for pycurl
- sudo apt-get -yq install libgnutls28-dev
- export PATH=$PWD/bin:$PATH
- pip install --upgrade pip setuptools
- ./ci/install.sh
- pip install --upgrade -r dev-requirements.txt
- npm install
- npm run webpack
- pip install --upgrade . -r helm-chart/images/binderhub/requirements.txt
- pip freeze

script:
- export BINDER_TEST_NAMESPACE=binder-test-$TEST
@@ -3,13 +3,10 @@ set -ex

mkdir -p bin

# install nsenter if missing (needed by kube on trusty)
if ! which nsenter; then
curl -L https://github.com/minrk/git-crypt-bin/releases/download/trusty/nsenter > nsenter
echo "5652bda3fbea6078896705130286b491b6b1885d7b13bda1dfc9bdfb08b49a2e nsenter" | shasum -a 256 -c -
chmod +x nsenter
sudo mv nsenter /usr/local/bin/
fi
# install gnutls headers for pycurl, socat for helm
sudo apt-get update
sudo apt-get -y install libgnutls28-dev socat


# Workaround for kube 1.10: https://github.com/kubernetes/kubernetes/issues/61058#issuecomment-372764783
sudo mount --make-rshared /

0 comments on commit b19d22e

Please sign in to comment.
You can’t perform that action at this time.