Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Remove duplicate dependencies from Gemfile.

Since we're using Jeweler to generate the gemspec, the dependencies
belong in the Rakefile.

This was already patched by @aub, but his pull request hasn't been
accepted yet. I'm including it here to keep things simple.
  • Loading branch information...
commit 495b66b6765ab463f2c59277cd4b4cc739816ca1 1 parent c6b6264
@adammck adammck authored
Showing with 53 additions and 77 deletions.
  1. +2 −20 Gemfile
  2. +9 −8 Rakefile
  3. +42 −49 health_graph.gemspec
View
22 Gemfile
@@ -1,20 +1,2 @@
-source "http://rubygems.org"
-# Add dependencies required to use your gem here.
-# Example:
-# gem "activesupport", ">= 2.3.5"
-
-gem "oauth2", "= 0.5.2"
-gem "faraday", "= 0.7.4"
-gem "faraday_middleware", "= 0.7.0"
-gem "hashie", "= 1.2"
-gem "json"
-
-# Add dependencies to develop your gem here.
-# Include everything needed to run rake, tests, features, etc.
-group :development do
- gem "shoulda", ">= 0"
- gem "webmock", "= 1.7.4"
- gem "bundler", "~> 1.0.0"
- gem "jeweler", "~> 1.6.4"
- gem "rcov", ">= 0"
-end
+source "https://rubygems.org"
+gemspec
View
17 Rakefile
@@ -13,7 +13,6 @@ require 'rake'
require 'jeweler'
Jeweler::Tasks.new do |gem|
- # gem is a Gem::Specification... see http://docs.rubygems.org/read/chapter/20 for more options
gem.name = "health_graph"
gem.homepage = "http://github.com/kennyma/health_graph"
gem.license = "MIT"
@@ -21,13 +20,15 @@ Jeweler::Tasks.new do |gem|
gem.description = "This is a wrapper for RunKeeper Health Graph RESTful API."
gem.email = "kenny@kennyma.me"
gem.authors = ["Kenny Ma"]
- # dependencies defined in Gemfile
- gem.add_dependency 'oauth2', '= 0.5.2'
- gem.add_dependency 'faraday', '= 0.7.4'
- gem.add_dependency 'faraday_middleware', '= 0.7.0'
- gem.add_dependency 'hashie', '= 1.2'
- gem.add_dependency 'webmock', '= 1.7.6'
- gem.add_dependency 'json'
+
+ gem.add_dependency "oauth2", ">= 0.5.2"
+ gem.add_dependency "faraday", ">= 0.7.4"
+ gem.add_dependency "faraday_middleware", ">= 0.7.8"
+ gem.add_dependency "hashie", ">= 1.2"
+ gem.add_dependency "webmock", ">= 1.7.6"
+
+ gem.add_development_dependency "shoulda"
+ gem.add_development_dependency "simplecov"
end
Jeweler::RubygemsDotOrgTasks.new
View
91 health_graph.gemspec
@@ -58,68 +58,61 @@ Gem::Specification.new do |s|
"test/helper.rb",
"test/test_health_graph.rb"
]
- s.homepage = %q{http://github.com/kennyma/health_graph}
+ s.homepage = "http://github.com/kennyma/health_graph"
s.licenses = ["MIT"]
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{Ruby gem for RunKeeper Health Graph API}
+ s.rubygems_version = "1.8.15"
+ s.summary = "Ruby gem for RunKeeper Health Graph API"
if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<oauth2>, ["= 0.5.2"])
- s.add_runtime_dependency(%q<faraday>, ["= 0.7.4"])
- s.add_runtime_dependency(%q<faraday_middleware>, ["= 0.7.0"])
- s.add_runtime_dependency(%q<hashie>, ["= 1.2"])
- s.add_runtime_dependency(%q<json>, [">= 0"])
+ s.add_runtime_dependency(%q<health_graph>, [">= 0"])
s.add_development_dependency(%q<shoulda>, [">= 0"])
- s.add_development_dependency(%q<webmock>, ["= 1.7.4"])
- s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_development_dependency(%q<rcov>, [">= 0"])
- s.add_runtime_dependency(%q<oauth2>, ["= 0.5.2"])
- s.add_runtime_dependency(%q<faraday>, ["= 0.7.4"])
- s.add_runtime_dependency(%q<faraday_middleware>, ["= 0.7.0"])
- s.add_runtime_dependency(%q<hashie>, ["= 1.2"])
- s.add_runtime_dependency(%q<webmock>, ["= 1.7.6"])
- s.add_runtime_dependency(%q<json>, [">= 0"])
+ s.add_development_dependency(%q<simplecov>, [">= 0"])
+ s.add_development_dependency(%q<shoulda>, [">= 0"])
+ s.add_development_dependency(%q<simplecov>, [">= 0"])
+ s.add_development_dependency(%q<shoulda>, [">= 0"])
+ s.add_development_dependency(%q<simplecov>, [">= 0"])
+ s.add_runtime_dependency(%q<oauth2>, [">= 0.5.2"])
+ s.add_runtime_dependency(%q<faraday>, [">= 0.7.4"])
+ s.add_runtime_dependency(%q<faraday_middleware>, [">= 0.7.8"])
+ s.add_runtime_dependency(%q<hashie>, [">= 1.2"])
+ s.add_runtime_dependency(%q<webmock>, [">= 1.7.6"])
+ s.add_development_dependency(%q<shoulda>, [">= 0"])
+ s.add_development_dependency(%q<simplecov>, [">= 0"])
else
- s.add_dependency(%q<oauth2>, ["= 0.5.2"])
- s.add_dependency(%q<faraday>, ["= 0.7.4"])
- s.add_dependency(%q<faraday_middleware>, ["= 0.7.0"])
- s.add_dependency(%q<hashie>, ["= 1.2"])
- s.add_dependency(%q<json>, [">= 0"])
+ s.add_dependency(%q<health_graph>, [">= 0"])
+ s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<simplecov>, [">= 0"])
+ s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<simplecov>, [">= 0"])
s.add_dependency(%q<shoulda>, [">= 0"])
- s.add_dependency(%q<webmock>, ["= 1.7.4"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_dependency(%q<rcov>, [">= 0"])
- s.add_dependency(%q<oauth2>, ["= 0.5.2"])
- s.add_dependency(%q<faraday>, ["= 0.7.4"])
- s.add_dependency(%q<faraday_middleware>, ["= 0.7.0"])
- s.add_dependency(%q<hashie>, ["= 1.2"])
- s.add_dependency(%q<webmock>, ["= 1.7.6"])
- s.add_dependency(%q<json>, [">= 0"])
+ s.add_dependency(%q<simplecov>, [">= 0"])
+ s.add_dependency(%q<oauth2>, [">= 0.5.2"])
+ s.add_dependency(%q<faraday>, [">= 0.7.4"])
+ s.add_dependency(%q<faraday_middleware>, [">= 0.7.8"])
+ s.add_dependency(%q<hashie>, [">= 1.2"])
+ s.add_dependency(%q<webmock>, [">= 1.7.6"])
+ s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<simplecov>, [">= 0"])
end
else
- s.add_dependency(%q<oauth2>, ["= 0.5.2"])
- s.add_dependency(%q<faraday>, ["= 0.7.4"])
- s.add_dependency(%q<faraday_middleware>, ["= 0.7.0"])
- s.add_dependency(%q<hashie>, ["= 1.2"])
- s.add_dependency(%q<json>, [">= 0"])
+ s.add_dependency(%q<health_graph>, [">= 0"])
+ s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<simplecov>, [">= 0"])
+ s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<simplecov>, [">= 0"])
+ s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<simplecov>, [">= 0"])
+ s.add_dependency(%q<oauth2>, [">= 0.5.2"])
+ s.add_dependency(%q<faraday>, [">= 0.7.4"])
+ s.add_dependency(%q<faraday_middleware>, [">= 0.7.8"])
+ s.add_dependency(%q<hashie>, [">= 1.2"])
+ s.add_dependency(%q<webmock>, [">= 1.7.6"])
s.add_dependency(%q<shoulda>, [">= 0"])
- s.add_dependency(%q<webmock>, ["= 1.7.4"])
- s.add_dependency(%q<bundler>, ["~> 1.0.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
- s.add_dependency(%q<rcov>, [">= 0"])
- s.add_dependency(%q<oauth2>, ["= 0.5.2"])
- s.add_dependency(%q<faraday>, ["= 0.7.4"])
- s.add_dependency(%q<faraday_middleware>, ["= 0.7.0"])
- s.add_dependency(%q<hashie>, ["= 1.2"])
- s.add_dependency(%q<webmock>, ["= 1.7.6"])
- s.add_dependency(%q<json>, [">= 0"])
+ s.add_dependency(%q<simplecov>, [">= 0"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.