Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[v1.16.1] informer-gen is broken for packages in a folder with a dot in them? #82860

Closed
ibuildthecloud opened this issue Sep 19, 2019 · 6 comments

Comments

@ibuildthecloud
Copy link
Contributor

commented Sep 19, 2019

What happened:

I have the folder pkg/apis/k3s.cattle.io/v1 where the folder k3s.cattle.io is the package k3s. Running informer-gen with v1.15 would produce pkg/generated/informers/externalversions/k3s.cattle.io/v1/ and the folder k3s.cattle.io would be the package k3s. In 1.16 the folder k3s.cattle.io generates code as the package k3s.cattle.io which is invalid and fails.

This change causes the issue 73dc5a9

@ibuildthecloud

This comment has been minimized.

Copy link
Contributor Author

commented Sep 19, 2019

/sig api-machinery
/area code-generation

@yue9944882

This comment has been minimized.

Copy link
Member

commented Sep 19, 2019

/cc @sttts

@liggitt

This comment has been minimized.

Copy link
Member

commented Sep 19, 2019

@liggitt liggitt added this to the v1.16 milestone Sep 19, 2019
@liggitt liggitt changed the title informer-gen is broken for packages in a folder with a dot in them? [v1.16.1] informer-gen is broken for packages in a folder with a dot in them? Sep 19, 2019
@fedebongio

This comment has been minimized.

Copy link
Contributor

commented Sep 19, 2019

/assign @sttts @nikhita

nikhita added a commit to nikhita/kubernetes that referenced this issue Sep 23, 2019
nikhita added a commit to nikhita/kubernetes that referenced this issue Sep 23, 2019
k8s-ci-robot added a commit to kubernetes/website that referenced this issue Sep 24, 2019
shturec added a commit to shturec/kubernetes that referenced this issue Sep 27, 2019
@nikhita

This comment has been minimized.

Copy link
Member

commented Sep 27, 2019

Fixed in #82410 and #83077 (will be present in v1.16.1)

/close

@k8s-ci-robot

This comment has been minimized.

Copy link
Contributor

commented Sep 27, 2019

@nikhita: Closing this issue.

In response to this:

Fixed in #82410 and #83077 (will be present in v1.16.1)

/close

Instructions for interacting with me using PR comments are available here. If you have questions or suggestions related to my behavior, please file an issue against the kubernetes/test-infra repository.

@runcom runcom referenced this issue Oct 2, 2019
ddebroy added a commit to ddebroy/kubernetes that referenced this issue Oct 10, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.