Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Sound issues with all gb/gbc games on Atmosphere Switch with 0.73 and newer nightlies #1532

Closed
Instandhaltung opened this issue Sep 26, 2019 · 4 comments
Labels

Comments

@Instandhaltung
Copy link

@Instandhaltung Instandhaltung commented Sep 26, 2019

The sound on gb/gbc games is buzzing and scratchy, often directly at the beginning of the emulation. When going to the menu of mgba, the sound works again until shortly later. It seems that the sound gets worse especially after a full screen redrawing (like changing from a game menu to gameplay), but it could be my imagination.

System: Switch with Atmosphere (FW8.1.0)
mGBA 0.7.3 and newer, older versions (if availabe) not tested
Overclock does not improve or worsen the problem

@endrift endrift added the os:Switch label Sep 27, 2019
@endrift endrift closed this in 4e81b8e Sep 30, 2019
@Instandhaltung

This comment has been minimized.

Copy link
Author

@Instandhaltung Instandhaltung commented Sep 30, 2019

I'd really like to try the new buildt, and although the change is visible in the "changes" file, it remains the same. The nro has the same size to the bit, so maybe it doesn't get updated properly. Is it possible to check that option? :)

Edit: I downloaded from the website under "Development downloads".

@endrift

This comment has been minimized.

Copy link
Member

@endrift endrift commented Sep 30, 2019

Looks like I somehow lost track of the source changes. I'll double check when I get home, but it was a relatively simple fix so I can redo it if I need to.

@endrift endrift reopened this Sep 30, 2019
@Instandhaltung

This comment has been minimized.

Copy link
Author

@Instandhaltung Instandhaltung commented Sep 30, 2019

Looks like I somehow lost track of the source changes. I'll double check when I get home, but it was a relatively simple fix so I can redo it if I need to.

Thanks for your hard work!

@endrift endrift closed this in c8cc2eb Oct 1, 2019
@Instandhaltung

This comment has been minimized.

Copy link
Author

@Instandhaltung Instandhaltung commented Oct 1, 2019

Thanks! It worked! :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.