Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Raw Game Fails to Load, but ELF Works #2192

Closed
ammrat13 opened this issue May 19, 2021 · 4 comments
Closed

Raw Game Fails to Load, but ELF Works #2192

ammrat13 opened this issue May 19, 2021 · 4 comments
Milestone

Comments

@ammrat13
Copy link

ammrat13 commented May 19, 2021

Running mGBA version 0.9.1 on Arch Linux from the repositories (package mgba-qt). CPU is AMD Ryzen 5 2600X. GPU is Nvidia GeForce GTX 1650 Super.

I'm trying to test my homebrew game on mGBA. Source, object file, ELF file, and GBA file are in test_game.zip. Loading the ELF file into mGBA works fine, but loading the GBA file gives

The game has crashed with the following error:
Jumped to invalid address: 00000000

@endrift
Copy link
Member

endrift commented May 19, 2021

I haven't looked at the file yet but my first guess is that it's misdetecting whether or not it's multiboot. Will look in depth in a bit.

@ammrat13
Copy link
Author

ammrat13 commented May 19, 2021

Probably. It's being loaded at 0x0200_0000 instead of 0x0800_0000.

@ammrat13
Copy link
Author

ammrat13 commented May 19, 2021

Resolved by making the ROM file 32MiB. Probably works because of the check here.

@endrift
Copy link
Member

endrift commented May 19, 2021

Yes, that check will resolve this, but I'm concerned that it's misdetecting regardless.

@ammrat13 ammrat13 reopened this May 19, 2021
@endrift endrift added this to the mGBA 0.10.0 milestone Jan 17, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

2 participants