Skip to content
Permalink
Browse files

doc: revoke DEP0089

Using the legacy assert module is not discouraged. Revoke
DEP0089 to avoid user confusion.

PR-URL: #28892
Fixes: #28780
Reviewed-By: Luigi Pinca <luigipinca@gmail.com>
Reviewed-By: Rich Trott <rtrott@gmail.com>
Reviewed-By: Anto Aravinth <anto.aravinth.cse@gmail.com>
Reviewed-By: Benjamin Gruenbaum <benjamingr@gmail.com>
  • Loading branch information...
cjihrig authored and targos committed Jul 29, 2019
1 parent d72b682 commit 5f07f49933d0f6be3ffb52e0f3ad4800caee6213
Showing with 7 additions and 4 deletions.
  1. +7 −4 doc/api/deprecations.md
@@ -1780,18 +1780,21 @@ cause a lot of issues. See <https://github.com/nodejs/node/issues/14328>.
### DEP0089: require('assert')
<!-- YAML
changes:
- version: REPLACEME
pr-url: https://github.com/nodejs/node/pull/28892
description: Deprecation revoked.
- version:
- v9.9.0
- v10.0.0
pr-url: https://github.com/nodejs/node/pull/17002
description: Documentation-only deprecation.
-->
Type: Documentation-only
Type: Deprecation revoked
Importing assert directly is not recommended as the exposed functions will use
loose equality checks. Use `require('assert').strict` instead. The API is the
same as the legacy assert but it will always use strict equality checks.
Importing assert directly was not recommended as the exposed functions use
loose equality checks. The deprecation was revoked because use of the `assert`
module is not discouraged, and the deprecation caused end user confusion.
<a id="DEP0090"></a>
### DEP0090: Invalid GCM authentication tag lengths

0 comments on commit 5f07f49

Please sign in to comment.
You can’t perform that action at this time.