Braille: Cannot use with speech off #1963

Closed
nvaccessAuto opened this Issue Nov 26, 2011 · 7 comments

2 participants

@nvaccessAuto

Reported by kevinchao89 on 2011-11-26 00:18
2011.3 Release
main-4802
Focus 40 Blue

via @Silverleaf57

When turning speech mode OFF, braille will not work in in any application. With snapshot, pressing any key will beep and release will do nothing. It should be possible to use braille only with speech off.

@nvaccessAuto

Comment 1 by kevinchao89 on 2011-11-26 00:40
Was working in 2011.1 and broke somewhere along the way. i.e. it's a regression.

@nvaccessAuto

Comment 2 by orcauser on 2011-11-26 00:55
you say beep, is it the error sound?
Would it be possible to provide a log?
Thanks

@nvaccessAuto

Comment 3 by jteh on 2011-11-26 04:13
Can't reproduce with either 2011.3 or latest main using a !HumanWare Brailliant (Baum driver), so it isn't braille in general. Please provide a log of the error.

@nvaccessAuto

Attachment Focus 40 Blue Braille.rtf added by kevinchao89 on 2011-11-26 19:14
Description:

@nvaccessAuto

Comment 4 by kevinchao89 on 2011-11-26 19:22
Yes, error sound, and log is attached.

@nvaccessAuto

Comment 5 by jteh on 2011-11-27 00:34
Okay. The user has their synthesiser set to "No speech". This is different to using speech mode off.

This is not related to braille. It will occur whenever the synthesiser is set to No speech with automatic language switching enabled. You can work around this by disabling automatic language switching in the Voice settings dialog.

Regression introduced by the auto language switching code.
Changes:
Milestone changed from None to 2012.1

@nvaccessAuto

Comment 6 by mdcurran on 2011-11-28 09:32
Fixed in f064079.
Changes:
State: closed

@jcsteh jcsteh was assigned by nvaccessAuto Nov 10, 2015
@nvaccessAuto nvaccessAuto added this to the 2012.1 milestone Nov 10, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment