New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

NVDA does not receive input from focus 40 blue connected through bluetooth #3401

Closed
nvaccessAuto opened this Issue Aug 4, 2013 · 6 comments

Comments

Projects
None yet
2 participants
@nvaccessAuto

nvaccessAuto commented Aug 4, 2013

Reported by aleksey_s on 2013-08-04 18:49
I have focus 40 blue display (not the latest model, but one with 2 rows of routing keys). If connected through bluetooth, NVDA is able to output the text on the display, but none of display buttons work (panning/routing/other controls). They do not produce any activity in input help mode either.

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Aug 4, 2013

Comment 1 by jteh on 2013-08-04 23:07
Someone else will need to debug this. Neither Mick or I own a FS bluetooth display, nor are we able to get access to one temporarily.

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Aug 5, 2013

Comment 2 by ragb on 2013-08-05 08:56
Hi,

I have the same braille display so I tried reproducing this.

I was able to reproduce it once: Gone to NVDA preferences, selected freedom scientific, bluetooth port and, in fact, no keys were working. However, I restarted NVDA and everything started working as expected. I tried setting the display to no braille and back to freedom scientific, and everything worked fine. Tried a couple of times, more restarts, and all works, so I'm afraid I can't reproduce it reliably again.

There are too possibilities for this: or we don't register the message window for the driver correctly (in the logs I can't see anything strange), or there is a problem with the FS dll somewhere. However, without a reliable way to reproduce this behaviour it will be difficult to debug.

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Nov 28, 2013

Comment 5 by James Teh <jamie@... on 2013-11-28 03:14
In [9dee70e]:

Freedom Scientific braille display driver: if  the driver cannot be initialized with any of the ports, make sure to clean up our message window and its window class. this this is not done, subsiquent successful initializations will fail to get braille display input as the message window could not be properly registered. Re #3662 Re #3401

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Nov 28, 2013

Comment 6 by jteh on 2013-11-28 03:21
This is very possibly fixed now. It'd be great if someone could confirm this.

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Nov 29, 2013

Comment 7 by aleksey_s on 2013-11-29 10:37
I can confirm this as being fixed. Thanks!
Changes:
State: closed

@nvaccessAuto

This comment has been minimized.

nvaccessAuto commented Nov 29, 2013

Comment 8 by jteh on 2013-11-29 21:39
Changes:
Milestone changed from None to 2013.3

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment