Add setup check for libxml2 >= 2.7.0 #23168

Closed
rullzer opened this Issue Mar 11, 2016 · 2 comments

Projects

None yet

4 participants

@rullzer
Contributor
rullzer commented Mar 11, 2016

As shown in #23054 (comment) we require at least libxml2-2.7.0.

I suspect this to be already the case for some time. But in 9.0 we switched to webdav also for the webUI.

Note libxml2-2.7.0 was released in august 2008. So it should not be a common issues.

Would be good to add a check for this in the setup warning.

@rullzer rullzer added this to the 9.1-current milestone Mar 11, 2016
@LukasReschke LukasReschke self-assigned this Mar 12, 2016
@LukasReschke LukasReschke added a commit that referenced this issue Mar 12, 2016
@LukasReschke LukasReschke Require at least libxml 2.7.0
Fixes #23168
42a70ed
@PVince81
Collaborator

I think Sabre 3.0 which we use in OC 9.0 is using a different XML approach, using some PHP XML methods. I guess these might be using libxml internally somehow...

@LukasReschke LukasReschke added a commit that referenced this issue Mar 16, 2016
@LukasReschke LukasReschke Require at least libxml 2.7.0
Fixes #23168
554066b
@LukasReschke LukasReschke added a commit that referenced this issue Mar 16, 2016
@LukasReschke LukasReschke Require at least libxml 2.7.0
Fixes #23168
dbcb037
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment