Skip to content
Permalink
Browse files

debian packaging update

  • Loading branch information
jef-n committed Feb 25, 2016
1 parent b0269be commit e0643f9d89bd4b1e56771d624db34c66ab442162
Showing with 4 additions and 3 deletions.
  1. +3 −3 debian/changelog
  2. +1 −0 debian/control.in
@@ -1,8 +1,8 @@
qgis (2.13.0) UNRELEASED; urgency=medium

* New development version 2.13 after branch of 2.12
* add dependencies to python-psycopg2, python-yaml, python-mack and
python-node2 for tests
* add dependencies to gdal-bin, python-psycopg2, python-yaml, python-mack
and python-node2 for tests

This comment has been minimized.

Copy link
@m-kuhn

m-kuhn Feb 25, 2016

Member

Should this be python-mock and python-nose2?

This comment has been minimized.

Copy link
@luipir

luipir Feb 25, 2016

Contributor

a gently reminder. AFAIK nose2 will be not ported to python3

This comment has been minimized.

Copy link
@jef-n

jef-n Feb 25, 2016

Author Member

psst. otherwise they'll probably remove this too ;)

$ apt-cache show python3-nose2
Package: python3-nose2
Source: nose2
Version: 0.5.0-2
Installed-Size: 443
Maintainer: Barry Warsaw 
Architecture: all
Depends: python3-pkg-resources, python3-six, python3, python3:any (>= 3.3.2-2~)
Suggests: python-nose2, python-nose2-doc
Description-en: next generation of nicer testing for Python (Python 3)
 This is the Python 3 package.
Description-md5: f3d7e24837af5a3d7f9e07bf62d44b7b
Homepage: https://pypi.python.org/pypi/nose2
Section: python
Priority: optional
Filename: pool/main/n/nose2/python3-nose2_0.5.0-2_all.deb
Size: 75558
MD5sum: 979b7c27c6057132d5e949d48efdb25b
SHA1: a691123cf07192d6ca823573b922bf4e33b5af17
SHA256: cf78ea62314afb86eee3b57c57d020a51f2109abeab7f74affb7e384c00b5e8b

This comment has been minimized.

Copy link
@luipir

luipir Feb 25, 2016

Contributor

sorry I was confused by the old nose

* update optional oracle dependency to 12.1
* upgrade python-qgis from Recommends to Depends
* downgrade liblwgeom dependency to Recommends
@@ -11,7 +11,7 @@ qgis (2.13.0) UNRELEASED; urgency=medium
* remove spit plugin
* add support for ubuntu xenial

-- Jürgen E. Fischer <jef@norbit.de> Sat, 20 Feb 2016 16:55:08 +0100
-- Jürgen E. Fischer <jef@norbit.de> Thu, 25 Feb 2016 09:29:24 +0100

qgis (2.12.0) unstable; urgency=medium

@@ -18,6 +18,7 @@ Build-Depends:
#precise# libgdal-dev (>= 1.9.0) | libgdal1-dev (<< 1.9.0),
#saucy# libgdal-dev (>= 1.9.0),
#wheezy# libgdal1-dev,
gdal-bin,
python-gdal,
libgeos-dev (>= 3.0.0),
libgsl-dev | libgsl0-dev,

0 comments on commit e0643f9

Please sign in to comment.
You can’t perform that action at this time.