Permalink
Browse files

Document ActiveRecord::Fixtures becoming ActiveRecord::FixtureSet

  • Loading branch information...
1 parent 74d471a commit a1d8b031d355fdbf9e93d26e33dfdac247c8a5f9 @trevorturk trevorturk committed Feb 28, 2013
Showing with 2 additions and 0 deletions.
  1. +2 −0 guides/source/upgrading_ruby_on_rails.md
View
2 guides/source/upgrading_ruby_on_rails.md
@@ -47,6 +47,8 @@ Rails 4.0 no longer supports loading plugins from `vendor/plugins`. You must rep
* Rails 4.0 has removed `attr_accessible` and `attr_protected` feature in favor of Strong Parameters. You can use the [Protected Attributes gem](https://github.com/rails/protected_attributes) to a smoothly upgrade path.
+* Rails 4.0 has deprecated `ActiveRecord::Fixtures` in favor of `ActiveRecord::FixtureSet`.
+
### Active Resource
Rails 4.0 extracted Active Resource to its own gem. If you still need the feature you can add the [Active Resource gem](https://github.com/rails/activeresource) in your Gemfile.

0 comments on commit a1d8b03

Please sign in to comment.