Skip to content
Permalink
Browse files
docs: Document update behavior for gems without version constraints (#…
  • Loading branch information
clemens committed Sep 9, 2021
1 parent 6eafd2f commit 0ee8440fe61424481f2055ba8ac9fdafb578d17c
Showing with 6 additions and 0 deletions.
  1. +6 −0 docs/usage/ruby.md
@@ -15,6 +15,12 @@ Renovate supports upgrading dependencies in Bundler's Gemfiles and their accompa
1. A PR is created which updates the `Gemfile` and `Gemfile.lock` in a single commit
1. If the source repository has a "changelog" file or uses GitHub releases, then Release Notes for each version are embedded in the generated PR

## Caveats

Renovate doesn't update dependencies without a version constraint.
Example: `gem 'some-gem', '~> 1.2.3'` will update `some-gem` if a new version matching the constraint is available, but `gem 'some-gem'` won't.
If you always want to have the latest available version, consider specifying `gem 'some-gem', '> 0'`.

## Enabling

You can install the [Renovate App](https://github.com/apps/renovate) on GitHub.

0 comments on commit 0ee8440

Please sign in to comment.