Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Deprecate validator-ajv6 in favor of validator-ajv8 before end of Beta #3110

Closed
3 of 4 tasks
heath-freenome opened this issue Sep 13, 2022 · 0 comments · Fixed by #3211
Closed
3 of 4 tasks

Deprecate validator-ajv6 in favor of validator-ajv8 before end of Beta #3110

heath-freenome opened this issue Sep 13, 2022 · 0 comments · Fixed by #3211
Assignees
Labels

Comments

@heath-freenome
Copy link
Contributor

heath-freenome commented Sep 13, 2022

Prerequisites

What theme are you using?

core

Version

5.0.0-beta.6

Current Behavior

Now that we have the validator-ajv8 we are going to want to deprecate the validator-ajv6. Update ALL of the documentation and tests so that validator-ajv8 is used.

@heath-freenome heath-freenome added bug needs triage Initial label given, to be assigned correct labels and assigned labels Sep 13, 2022
@heath-freenome heath-freenome changed the title Deprecate validator-ajv6 in favor of validator-ajv8 Deprecate validator-ajv6 in favor of validator-ajv8 before end of Beta Sep 13, 2022
@heath-freenome heath-freenome added p1 and removed needs triage Initial label given, to be assigned correct labels and assigned labels Sep 23, 2022
heath-freenome added a commit to heath-freenome/react-jsonschema-form that referenced this issue Oct 26, 2022
Fix rjsf-team#3110 by deprecating the `@rjsf/validator-ajv6` and improving documentation

- Updated the `README.md` and all files in the `@rjsf/validator-ajv6` as deprecated
- Updated the tests for all themes to switch to using the `@rjsf/validator-ajv8`
  - Due to the changes in messaging syntax with the ajv 8 validator most of the tests that displayed errors needed to be updated
- Updated all of the documentation to be Typescript syntax, switching all examples to `@rjsf/validator-ajv8` with the exception of those few examples specifically for the `@rjsf/validator-ajv6`
- Updated the playground to default to the AJV8 validator and marking the AJV6 validator as deprecated
- Updated the `CHANGELOG.md` accordingly
heath-freenome added a commit to heath-freenome/react-jsonschema-form that referenced this issue Oct 26, 2022
Fix rjsf-team#3110 by deprecating the `@rjsf/validator-ajv6` and improving documentation

- Updated the `README.md` and all files in the `@rjsf/validator-ajv6` as deprecated
- Updated the tests for all themes to switch to using the `@rjsf/validator-ajv8`
  - Due to the changes in messaging syntax with the ajv 8 validator most of the tests that displayed errors needed to be updated
- Updated all of the documentation to be Typescript syntax, switching all examples to `@rjsf/validator-ajv8` with the exception of those few examples specifically for the `@rjsf/validator-ajv6`
- Updated the playground to default to the AJV8 validator and marking the AJV6 validator as deprecated
- Updated the `CHANGELOG.md` accordingly
heath-freenome added a commit to heath-freenome/react-jsonschema-form that referenced this issue Oct 26, 2022
Fix rjsf-team#3110 by deprecating the `@rjsf/validator-ajv6` and improving documentation

- Updated the `README.md` and all files in the `@rjsf/validator-ajv6` as deprecated
- Updated the tests for all themes to switch to using the `@rjsf/validator-ajv8`
  - Due to the changes in messaging syntax with the ajv 8 validator most of the tests that displayed errors needed to be updated
- Updated all of the documentation to be Typescript syntax, switching all examples to `@rjsf/validator-ajv8` with the exception of those few examples specifically for the `@rjsf/validator-ajv6`
- Updated the playground to default to the AJV8 validator and marking the AJV6 validator as deprecated
- Updated the `CHANGELOG.md` accordingly
heath-freenome added a commit that referenced this issue Oct 26, 2022
* fix: #3110 by deprecating the ajv 6 validator
Fix #3110 by deprecating the `@rjsf/validator-ajv6` and improving documentation

- Updated the `README.md` and all files in the `@rjsf/validator-ajv6` as deprecated
- Updated the tests for all themes to switch to using the `@rjsf/validator-ajv8`
  - Due to the changes in messaging syntax with the ajv 8 validator most of the tests that displayed errors needed to be updated
- Updated all of the documentation to be Typescript syntax, switching all examples to `@rjsf/validator-ajv8` with the exception of those few examples specifically for the `@rjsf/validator-ajv6`
- Updated the playground to default to the AJV8 validator and marking the AJV6 validator as deprecated
- Updated the `CHANGELOG.md` accordingly

* - fix build

* Update docs/5.x upgrade guide.md

- Accepting reviewer feedback

Co-authored-by: Nick Grosenbacher <nickgrosenbacher@gmail.com>

* Update docs/usage/validation.md

- Accepting reviewer feedback

Co-authored-by: Nick Grosenbacher <nickgrosenbacher@gmail.com>

Co-authored-by: Nick Grosenbacher <nickgrosenbacher@gmail.com>
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

Successfully merging a pull request may close this issue.

3 participants