Skip to content
This repository has been archived by the owner. It is now read-only.
master
Switch branches/tags
Code

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time

react-native-webgl is deprecated

Since react-native-unimodules was introduced we can now use Expo modules like expo-gl which is where the webgl implementation has been continued and is actively maintained.

We therefore recommend you now move to use expo-gl:

You will need a react-native-unimodules setup

yarn add react-native-unimodules

If it's the first time you install react-native-unimodules, you will have to carefully follow the documentation to configure your project: configure unimodules (if not yet done)

You can then install expo-gl dependencies:

yarn add expo-gl expo-gl-cpp

If you use gl-react-native

Upgrade to latest version of gl-react-native that now depends on expo-gl and expo-gl-cpp (you don't need to install it, it also won't depend on this package anymore).

About

DEPRECATED: use expo-gl – Implements WebGL for react-native

Topics

Resources

Packages

No packages published