Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

theme agnoster show "?" #4756

Closed
lubeast opened this Issue Jan 7, 2016 · 5 comments

Comments

Projects
None yet
4 participants
@lubeast
Copy link

commented Jan 7, 2016

I know maybe a lot of people have asked this question before, and i searched a lot on the internet.
I've already install powerline-font but it still show this.

what should i do?

@apjanke

This comment has been minimized.

Copy link
Contributor

commented Jan 8, 2016

You may have an outdated Powerline font. Download fresh ones from the main Powerline fonts repo, and make sure your Oh My Zsh installation is also up to date.

If you are using iTerm2 or another terminal emulator that has separate selections for "non-ASCII" fonts, make sure the "Non-ASCII Font" in your terminal profile is also set to a Powerline font.

See #1906, #4091, #4083, #3713, #2869.

Somebody needs to write a FAQ on this. :)

@lubeast

This comment has been minimized.

Copy link
Author

commented Jan 8, 2016

@apjanke Thank you for your answer :D

I redownload Powerline fonts repo and reinstall oh-my-zsh.But it still doesn't work for me. So I change font from menlo to Meslo LG M Regular for Powerline and that work for me.

Once again, thank you for your professional answer. It's really need someone to write a FAQ about this.

@apjanke

This comment has been minimized.

Copy link
Contributor

commented Jan 8, 2016

You're welcome!

So I change font from menlo to Meslo LG M Regular for Powerline and that work for me.

Yes, that is what you should do. "Menlo" is a classic font. "Meslo" is a derivative of "Menlo". And "Meslo XXX for Powerline" is a non-standard Powerline-patched derivative of "Meslo", which is what you need to make Agnostor and other Powerline-dependent themes work.

Sorry for any confusion! (And this is not your fault; you just ran in to a compabibility/licensing/release-management/font-fallback/private-use-area mess.)

@audiebantzhan

This comment has been minimized.

Copy link

commented Jan 11, 2016

change font from menlo to Meslo LG M Regular for Powerline ,it work for me.

@tolerious

This comment has been minimized.

Copy link

commented Nov 16, 2016

yes, we should change the terminal fonts.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.