Skip to content
This repository
Browse code

dev: add warning with solution for ruby-debug19 issues when installin…

…g the bundle on ruby-1.9.3
  • Loading branch information...
commit e61595a965d9e7762418bc7b83ddc9af4c1bda11 1 parent 1707be8
David Chelimsky authored November 24, 2011

Showing 1 changed file with 14 additions and 5 deletions. Show diff stats Hide diff stats

  1. 19  Gemfile
19  Gemfile
@@ -31,11 +31,20 @@ group :development do
31 31
   end
32 32
 
33 33
   platforms :mri_19 do
34  
-    if RUBY_VERSION == '1.9.2'
35  
-      gem 'linecache19', '~> 0.5.12'
36  
-      gem 'ruby-debug19', '~> 0.11.6'
37  
-      gem 'ruby-debug-base19', '~> 0.11.25'
38  
-    end
  34
+    warn <<-EOM if RUBY_VERSION == '1.9.3'
  35
+    ruby-debug19 on ruby-1.9.3 requires gems that have not been released to
  36
+    rubygems as of 2011-11-24:
  37
+
  38
+      ruby-debug-base19-0.11.26
  39
+      linecache19-0.5.13
  40
+
  41
+    See http://blog.wyeworks.com/2011/11/1/ruby-1-9-3-and-ruby-debug if they
  42
+    still haven't been released and you're having trouble using ruby-debug19.
  43
+    EOM
  44
+
  45
+    gem 'ruby-debug19',      '~> 0.11.6'
  46
+    gem 'ruby-debug-base19', '~> 0.11.25'
  47
+    gem 'linecache19',       '~> 0.5.12'
39 48
   end
40 49
 
41 50
   platforms :mri_18, :mri_19 do

0 notes on commit e61595a

Please sign in to comment.
Something went wrong with that request. Please try again.