Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

TASTy reader: add support for Scala 3.0.0-M2 #9357

Merged
merged 2 commits into from Dec 4, 2020

Conversation

@bishabosha
Copy link
Member

@bishabosha bishabosha commented Dec 3, 2020

  • Drops support for 3.0.0-M1

If we wanted to support both 3.0.0-M1 and 3.0.0-M2 that could be possible at least in this release, future releases of scala 3 may make more serious changes. If we did, I think in tastytest it would be simple enough to support versioned source directories, but mamaging the different scala 3 versions in classloaders would be more tricky

cc @sjrd

bishabosha added 2 commits Dec 2, 2020
this commit does not implement backwards compatability for
tasty unpickling, perhaps that may be desireable
@scala-jenkins scala-jenkins added this to the 2.13.5 milestone Dec 3, 2020
@bishabosha bishabosha requested review from lrytz, sjrd and dwijnand Dec 3, 2020
@sjrd
Copy link
Member

@sjrd sjrd commented Dec 3, 2020

IMO, until 3.0.0 we can afford to support only one version. That's the advantage of a -Y flag. After 3.0.0 we'll have to support all versions since 3.0.0 (like the dotty compiler itself will have to do).

@SethTisue SethTisue merged commit 1360aef into scala:2.13.x Dec 4, 2020
4 checks passed
@SethTisue
Copy link
Member

@SethTisue SethTisue commented Dec 4, 2020

folks needing prompt access to this can use a nightly build of 2.13.5

@sjrd sjrd deleted the tasty/support-3.0.0-M2 branch Dec 4, 2020
@SethTisue SethTisue changed the title Tasty Reader: support 3.0.0-M2 TASTy reader: add support for Scala 3.0.0-M2 Feb 19, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
4 participants