Permalink
Browse files

Merge remote-tracking branch 'codebrew/master'

  • Loading branch information...
2 parents 4292aaa + 3a1b764 commit 5c9b789573060a30ea78b01abc495ffbd6f0a758 Yuri Gadow committed Jan 25, 2012
Showing with 58 additions and 58 deletions.
  1. +1 −1 Gemfile
  2. +51 −51 Gemfile.lock
  3. +5 −5 README.md
  4. +1 −1 backbone-rails.gemspec
View
2 Gemfile
@@ -1,6 +1,6 @@
source "http://rubygems.org"
-gem "rails", "~> 3.1.1"
+gem "rails", "~> 3.2.0"
# Bundle edge Rails instead:
# gem 'rails', :git => "git://github.com/rails/rails.git", :branch => "3-1-stable"
# gem 'tilt', :git => "git://github.com/rtomayko/tilt.git"
View
102 Gemfile.lock
@@ -1,90 +1,90 @@
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.1.1)
- actionpack (= 3.1.1)
- mail (~> 2.3.0)
- actionpack (3.1.1)
- activemodel (= 3.1.1)
- activesupport (= 3.1.1)
+ actionmailer (3.2.0)
+ actionpack (= 3.2.0)
+ mail (~> 2.4.0)
+ actionpack (3.2.0)
+ activemodel (= 3.2.0)
+ activesupport (= 3.2.0)
builder (~> 3.0.0)
erubis (~> 2.7.0)
- i18n (~> 0.6)
- rack (~> 1.3.2)
+ journey (~> 1.0.0)
+ rack (~> 1.4.0)
rack-cache (~> 1.1)
- rack-mount (~> 0.8.2)
rack-test (~> 0.6.1)
- sprockets (~> 2.0.2)
- activemodel (3.1.1)
- activesupport (= 3.1.1)
+ sprockets (~> 2.1.2)
+ activemodel (3.2.0)
+ activesupport (= 3.2.0)
builder (~> 3.0.0)
- i18n (~> 0.6)
- activerecord (3.1.1)
- activemodel (= 3.1.1)
- activesupport (= 3.1.1)
- arel (~> 2.2.1)
+ activerecord (3.2.0)
+ activemodel (= 3.2.0)
+ activesupport (= 3.2.0)
+ arel (~> 3.0.0)
tzinfo (~> 0.3.29)
- activeresource (3.1.1)
- activemodel (= 3.1.1)
- activesupport (= 3.1.1)
- activesupport (3.1.1)
+ activeresource (3.2.0)
+ activemodel (= 3.2.0)
+ activesupport (= 3.2.0)
+ activesupport (3.2.0)
+ i18n (~> 0.6)
multi_json (~> 1.0)
ansi (1.4.1)
archive-tar-minitar (0.5.2)
- arel (2.2.1)
+ arel (3.0.0)
builder (3.0.0)
coffee-script (2.2.0)
coffee-script-source
execjs
- coffee-script-source (1.1.2)
- columnize (0.3.4)
+ coffee-script-source (1.2.0)
+ columnize (0.3.6)
ejs (1.0.0)
erubis (2.7.0)
- execjs (1.2.4)
+ execjs (1.3.0)
multi_json (~> 1.0)
hike (1.2.1)
i18n (0.6.0)
- jquery-rails (1.0.13)
- railties (~> 3.0)
+ journey (1.0.0)
+ jquery-rails (2.0.0)
+ railties (>= 3.2.0.beta, < 5.0)
thor (~> 0.14)
- json (1.6.1)
+ json (1.6.5)
linecache19 (0.5.12)
ruby_core_source (>= 0.1.4)
- mail (2.3.0)
+ mail (2.4.1)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
+ metaclass (0.0.1)
mime-types (1.17.2)
- minitest (2.5.1)
- mocha (0.9.12)
- multi_json (1.0.3)
+ minitest (2.10.1)
+ mocha (0.10.3)
+ metaclass (~> 0.0.1)
+ multi_json (1.0.4)
polyglot (0.3.3)
- rack (1.3.5)
+ rack (1.4.0)
rack-cache (1.1)
rack (>= 0.4)
- rack-mount (0.8.3)
- rack (>= 1.0.0)
rack-ssl (1.3.2)
rack
rack-test (0.6.1)
rack (>= 1.0)
- rails (3.1.1)
- actionmailer (= 3.1.1)
- actionpack (= 3.1.1)
- activerecord (= 3.1.1)
- activeresource (= 3.1.1)
- activesupport (= 3.1.1)
+ rails (3.2.0)
+ actionmailer (= 3.2.0)
+ actionpack (= 3.2.0)
+ activerecord (= 3.2.0)
+ activeresource (= 3.2.0)
+ activesupport (= 3.2.0)
bundler (~> 1.0)
- railties (= 3.1.1)
- railties (3.1.1)
- actionpack (= 3.1.1)
- activesupport (= 3.1.1)
+ railties (= 3.2.0)
+ railties (3.2.0)
+ actionpack (= 3.2.0)
+ activesupport (= 3.2.0)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (~> 0.14.6)
rake (0.9.2.2)
- rdoc (3.11)
+ rdoc (3.12)
json (~> 1.4)
ruby-debug-base19 (0.11.25)
columnize (>= 0.3.1)
@@ -96,12 +96,12 @@ GEM
ruby-debug-base19 (>= 0.11.19)
ruby_core_source (0.1.5)
archive-tar-minitar (>= 0.5.2)
- sass (3.1.7)
- sprockets (2.0.3)
+ sass (3.1.12)
+ sprockets (2.1.2)
hike (~> 1.2)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
- sqlite3 (1.3.4)
+ sqlite3 (1.3.5)
thor (0.14.6)
tilt (1.3.3)
treetop (1.4.10)
@@ -110,7 +110,7 @@ GEM
turn (0.8.3)
ansi
tzinfo (0.3.31)
- uglifier (1.0.2)
+ uglifier (1.2.2)
execjs (>= 0.3.0)
multi_json (>= 1.0.2)
@@ -123,7 +123,7 @@ DEPENDENCIES
jquery-rails
minitest
mocha (>= 0.9.12)
- rails (~> 3.1.1)
+ rails (~> 3.2.0)
ruby-debug19
sass
sqlite3
View
10 README.md
@@ -1,11 +1,11 @@
# Backbone-Rails [![Build Status](https://secure.travis-ci.org/codebrew/backbone-rails.png)](http://travis-ci.org/codebrew/backbone-rails)
-Easily setup and use backbone.js (0.5.3) with rails 3.1
+Easily setup and use backbone.js (0.5.3) with rails 3.1 and greater
Follow [@TheRyanFitz on Twitter](http://twitter.com/#!/TheRyanFitz). Tweet any questions or suggestions you have about the project.
-## Rails 3.1 setup
-This gem requires the use of rails 3.1, coffeescript and the new rails asset pipeline provided by sprockets.
+## Rails setup
+This gem requires the use of rails 3.1 and greater, coffeescript and the new rails asset pipeline provided by sprockets.
This gem vendors the latest version of underscore.js and backbone.js for Rails 3.1 and greater. The files will be added to the asset pipeline and available for you to use.
@@ -32,7 +32,7 @@ Running `rails g backbone:install` will create the following directory structure
It will also create a toplevel app_name.coffee file to setup namespacing and setup initial requires.
## Generators
-backbone-rails provides 3 simple generators to help get you started using backbone.js with rails 3.1.
+backbone-rails provides 3 simple generators to help get you started using backbone.js with rails 3.1 and greater.
The generators will only create client side code (javascript).
### Model Generator
@@ -55,7 +55,7 @@ This generator creates a router, views, templates, model and collection to creat
## Example Usage
-Created a new rails 3.1 application called `blog`.
+Created a new rails application called `blog`.
rails new blog
View
2 backbone-rails.gemspec
@@ -2,7 +2,7 @@
# project in your rails apps through git.
Gem::Specification.new do |s|
s.name = "rails-backbone"
- s.version = "0.6.0"
+ s.version = "0.6.1"
s.authors = ["Ryan Fitzgerald", "Code Brew Studios"]
s.email = ["ryan@codebrewstudios.com"]
s.homepage = "http://github.com/codebrew/backbone-rails"

0 comments on commit 5c9b789

Please sign in to comment.