Skip to content

@snipe snipe released this Apr 27, 2021 · 32 commits to master since this release

⚠️ IMPORTANT: 5.2.x versions of Snipe-IT will require PHP 7.4 or greater.

(This is a requirement in order for us to be able to pull forward the dependencies that will allow us to support PHP8 and beyond moving forward.)

This is largely a bug fix release that tries to catch us up on older PRs. (We started v5.1.4 with over 60 PRs, we now have about 9.) There are some minor docker fixes here, some UI improvements, and some LDAP improvements.

New in v5.1.5

  • Enable use of custom file based SAML certificate/private key
  • Updated languages
  • Set docker user as owner of key symbolic links (#7924)
  • Fixed typo that doesn't accept textarea as custom field type element
  • Fixed label name for field_values in custom fields edit
  • Increases DPI of barcode for small lables (#9344)
  • Extended #6229 to include superuser permission check (#6772)
  • Fix Ubuntu Vagrant Development VMs (#6909)
  • Use environmental variables in memory limits
  • Improvement for auditing feature on mobile [ch14328] (#9181)
  • Fixed #9404 - include note in accessory API
  • Removed deprecated Input:: facade
  • Fixed an issue with CSS when the 'skin' value in settings table is empty
  • Fixed logic to handle when a cloned user is imported via LDAP. (#9429)
  • Fixed Sum of purchase cost of components not taking quantity into account in Asset View > Components tab
  • Updated snipeit.sh php version from 7.1 to 7.4 (#9407)
  • Fixed #9372 - Error getting users from LDAP directory, error: ldap_search(): Search: Can't contact LDAP server
  • Handle regex format for custom fields when assigned from API (#9443)
  • Fixed #9447 change route parameter name in locations view (#9456)
  • Fix for css when running Snipe-IT in subdirectory (#9445)
  • (Maybe?) Fixes the problem where we always need the php-ldap extension enabled (implements deferred service provider) (#9321)
  • Changed “Asset Categories” to “Categories” since there are more than asset categories now
  • Fixed #9424: import history adds asset model to assigned user and respects checkin date (#9350)
  • Fixed ldap ad authentication filter query mechanism (#7441)
  • Fixed the controller signature error people are getting with LDAP logins (#9466)
  • Restore LOG_CHANNEL environment variable regression. (#9464)

Added

  • Added sanity check to determine if a bind user account is set. (#9340)
  • Added a way for a user to override the site skin setting
  • Added #6695: add API endpoint for license seats (#8058)
  • Added created_at and updated_at to Asset Model presenter
  • Added additional LDAP fields to sync (#9318) - resolves #7211, #9197, #7864, [ch15504]
  • Added support for Debian 10 (#7414)
  • Added #5977: permission to view files attached to licenses (#9264)
  • Added option to force TLS connection (#9327)
  • Added ID columns to tables that don’t have them - reproduces #9363
  • Added check for valid category name on user's view-assets page
  • Added #9355: include Accessories and Consumables on the location reports
  • Added show() redirect for CustomFields::show() - this is mostly to prevent junking up Rollbar when people are experimenting
  • Added help text to custom fields headline
  • Added #9313: Add new fpm-alpine docker image and docker secrets support
  • Added a docker-compose with helper services (#9105)
  • Added clearer reporting on import when the mime type is incorrect
  • Improved UI for importer file listing
  • Adding text/x-Algol68 to import because WTF
  • Added user locale to REST API GET /api/users response (#9486)

For a full list of changes, see the complete changelog.

Upgrading

For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

Assets 2