SublimeLinter plugin for python, using pydocstyle.
Clone or download
Latest commit cf9c237 May 11, 2018
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
messages pre-spring cleaning Dec 29, 2017
.gitignore Added standard .gitignore. Apr 8, 2014
.travis.yml screw this Dec 13, 2017
LICENSE Completed package. Dec 15, 2013
README.md update readme Apr 2, 2018
linter.py Do not define what is the default anyway May 11, 2018
messages.json Update to Pydocstyle May 17, 2016
setup.cfg use interoperable linter config Dec 13, 2017

README.md

SublimeLinter-pydocstyle

Build Status

This linter plugin for SublimeLinter provides an interface to pydocstyle. It will be used with files that have the "Python" syntax.

Installation

SublimeLinter must be installed in order to use this plugin.

Please use Package Control to install the linter plugin.

Before installing this plugin, ensure that pydocstyle (0.3.0 or later) is installed on your system. To install pydocstyle, do the following:

  1. Install Python and pip.

  2. Install pydocstyle by typing the following in a terminal:

    [sudo] pip install pydocstyle
    

Please make sure that the path to pydocstyle is available to SublimeLinter. The docs cover troubleshooting PATH configuration.

Settings