Skip to content

CVE 2021 22160

Lari Hotari edited this page Sep 23, 2022 · 3 revisions
Clone this wiki locally

CVE-2021-22160 Authentication with JWT allows use of "none"-algorithm

Apache Pulsar Information Disclosure

Severity: High

Versions Affected:

Apache Pulsar < 2.7.1

Description:

If Apache Pulsar is configured to authenticate clients using tokens based on JSON Web Tokens (JWT), the signature of the token is not validated if the algorithm of the presented token is set to "none". This allows an attacker to connect to Pulsar instances as any user (incl. admins).

Mitigation:

Users of the affected versions should apply one of the following mitigations: Upgrade to Apache Pulsar 2.7.1 or later

Credit:

This issue was identified by Peter Stöckli

RELATED LINKS:

CVE-2021-22160 at cve.mitre.org https://lists.apache.org/thread.html/r347650d15a3e9c5f58b83e918b6ad6dedc2a63d3eb63da8e6a7be87e%40%3Cusers.pulsar.apache.org%3E

Security Advisories